icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.tztqwl.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

千亿彩票 www.cp9688.com-今日中彩可靠吗| www.xv05.com-福利彩票开店南宁| www.3667.vip-周末什么彩票开奖| www.636782.com-小鸡彩虹片头曲| www.730781.com-天天竞彩是正规的吗| www.835198.com-缅甸好彩烟-| www.009059.com-七星彩专家杀号预测| www.331483.com-球彩票走势图大全| www.775093.com-福彩公益金是什么| www.933682.com-吉彩彩票是什么东西| 大赢家彩票平台www.068675.com| www.nc19.com-乐米彩票安装包| www.668870.com-体彩排列三图吧| www.743905.com-酷彩app真的吗| www.813045.com-微信登录天天中彩票| www.0ce.com-常笑体彩店苹果下载| www.62pl.com-彩票的税是多少钱啊| www.4334.top-旺彩票头奖运| www.889178.com-易彩网怎么注册| www.129497.com-南京众彩免费班车| www.893736.com-爱购彩旧版本| 彩82www.c9223.com| www.6503.top-斗牛彩票主管| www.050212.com-怎么做到赢黑彩| www.507622.com-内蒙古体彩网双色球| www.587387.com-昨晚彩票开奖| www.659945.com-名人彩票娱乐| www.279693.com-七乐彩中奖号查询| www.956045.com-3d彩票谜语图便民| www.cp193.cc-彩票平台下载| www.170752.com-河南快三一码遗漏| www.278287.com-玩分分彩app| www.370164.com-分分中彩吧-| www.508696.com-手机怎样玩体彩| www.xs72.com-彩票688下载| www.051601.com-3d福彩试机号金码| www.132652.com-众够彩票网-| www.606760.com-世界杯足彩结果| www.33729.cc-米多彩票-| www.042642.com-足彩欧冠十四场技巧| www.150570.com-360彩票软件| www.386625.com-韩国有足球彩票吗| www.535550.com-生肖彩票网站最新| www.702422.com-聚星彩票下载| www.14087.com-体彩大乐透官网下载| www.79319.com-彩票方案佣金怎么选| www.099673.com-365娱乐彩票| www.191585.com-内蒙时时彩中奖技巧| www.9550.top-福彩6加1开奖号码| www.987438.com-皇都彩票全部彩种| www.728011.com-名人彩票登录页面| www.811348.com-排列三论坛家彩网| www.897472.com-彩99是合法的吗| www.972064.com-全国体彩22选5| www.cp6558.com-江苏e球彩走势图| www.th25.com-湖壮快三一定牛预测| www.882817.com-易彩国际犯法吗| www.515456.com-在哪买七星彩| www.766874.com-足彩比分新浪网| www.44579.com-福彩东方61走势图| www.724822.com-兼职彩票投注手| www.847809.com-彩票怎么挂机比较好| www.929662.com-七星彩抓规公式| www.io93.com-7号彩票注册邀请码| www.d99.biz-竞彩多久可以兑奖| www.516058.com-领航彩票小网址| www.603195.com-双色球快三多少钱| www.677002.com-香港彩宝典| www.773032.com-中奖彩票图-| www.859231.com-6加1彩票开奖结果| www.941600.com-eg彩票平台导航| 大赢家彩票平台www.715920.com| www.pe79.com-河北快三推荐三同号| www.55834.cc-七星彩历史开奖对比| www.063186.com-福彩机子可以退吗| www.151191.com-福彩3d秘诀彩经网| www.228077.com-七星彩最近十期| www.x13.org-赚彩票-| www.89fn.com-有谁玩鼎博博彩的吗| www.668631.com-非凡彩票下载安装| www.751078.com-九彩彩票下载安装| www.818187.com-足球彩票必发指数| www.908148.com-七星彩历史最大奖| www.964205.com-500彩票欢迎您| www.cai869.cc-福彩上海快3| www.655919.com-玩彩票怎么玩不赔| www.nw25.com-快三彩票是不是赌博| www.2325.net-七乐彩连线走势图| www.379879.com-我在洪荒买彩票| www.360049.com-三亚私彩举报| www.146518.com-首页竞彩网开奖| www.pr80.com-掌上彩-| www.011669.com-竞彩篮球彩票app| 博友彩www.941194.com| www.08zl.com-世界杯彩票玩法| www.fm43.com-彩票网500-| www.692851.com-足彩即时比分彩客| www.077342.com-高频彩有哪几种| www.785883.com-北京福彩专刊| www.909595.com-九宫预测时时彩| www.992158.com-360竞彩篮球| www.jj07.com-彩票福彩3d字迷| www.74mo.com-万豪彩票可以代理吗| www.604411.com-举报彩票平台有奖吗| www.759598.com-彩王娱乐app| www.912390.com-做私彩代理能赚多少| www.y65.com-彩票真能中奖吗| www.6762.cm-如意彩可靠吗| www.932621.com-重庆时时彩官方电话| www.987491.com-广西福彩中心兑奖室| www.ik9.cc-内蒙古爱彩乐| www.008298.com-星期五福彩开奖吗| www.7177.in-一起博彩分分彩| www.155.bid-香港福利彩票结果| www.3747.com-大彩网快三-| www.rm84.com-福彩关闭时间| www.70495.com-宁波亿彩购物中心| www.055507.com-福彩快三规律走势图| www.621433.com-福利彩票51亿| www.748536.com-中彩啦怎样下载| www.808080.com-中国官方足球竞彩网| www.t77.top-如何摆脱彩票托| www.0330.loan-釉上彩瓷器出手| www.238303.com-中国福彩网开奖直播| www.232900.com-好彩网是诈骗网站吗| www.385100.com-彩票源码php| www.502420.com-福建彩票兑奖在哪里| www.594067.com-优乐炫彩彩票平台| www.691961.com-大乐透开奖结果彩票| www.783646.com-爱彩彩票破解器| www.091010.com-搜索福彩图谜总汇| www.5865.xyz-延吉市彩票站| www.08110.com-wj686旺角彩皇| www.44807.com-福彩网上赚钱真假| www.80185.com-江苏快三遗漏爱彩| www.57571.cc-皇冠体彩安全吗| www.85535.cc-下载爱博彩票| www.gv18.com-彩6官方下载app| www.xc05.com-彩中彩坑人骗局| www.04ok.com-水彩风景画-| www.63km.com-彩票开奖查询| www.972324.com-福彩3d一定牛下载| www.861308.com-500万彩票-| www.dr56.com-新浪数字彩票汇总| www.f13.cn-查看七乐彩彩票| www.02308.com-什么叫问题彩民| www.87bn.com-搜索彩吧3d-| www.062324.com-立彩tl团队-| www.188341.com-7070彩票开挂| www.345942.com-彩票赢家与你同行| www.zm0.com-高频选5彩票软件| www.62751.cc-大发快三在线看计划| www.79395.com-香港首创彩金| www.081801.com-七星彩网上怎么买| www.761327.com-中彩票的税-| www.824628.com-万博博彩app地址| www.899134.com-310足彩报-| www.967984.com-上海福彩快3明细图| www.aj99.com-七星彩秘诀-| www.0701.xyz-彩票网站建设ag| www.218752.com-福建福彩双色球| www.4723.org-好像中彩票-| 13e彩票www.373170.com| www.800021.cc-福利彩票基诺游戏|